Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /public_html/opencart/system/database/mysql.php on line 6
Pré-requis

Documentation - Pré-requis

Pré-requis

OpenCart peut être installé sur tout serveur d'hébergement disposant au moins de :

  • Apache ou Windows IIS
  • PHP 5
  • MySQL

OpenCart ne fonctionnera pas correctement (ou pas du tout) sans ces technologies.

Si votre hébergement ne dispose pas de ces ressources, vous pouvez généralement contacter le support technique de votre hébergeur pour en demander leur installation. Cette modification peut chez certains hébergeurs entraîner un surcoût de votre abonnement.

Vous pouvez vérifier que votre serveur d'hébergement est bien compatible avec OpenCart en invoquant la commande phpinfo() via un fichier déposé à la racine de votre serveur. Voici la marche à suivre :

  1. À l’aide d’un éditeur de texte (Notepad++ sous Windows ou TextEdit sous MacOS X), créez un nouveau fichier dans lequel vous collerez la ligne de code suivante : 
    <?php phpinfo(); ?>
  2. Enregistrez le fichier sous un nom de votre choix – par exemple : info.php. L’extension PHP est essentielle. 
  3. Envoyez ce fichier à la racine de votre serveur à l’aide de votre client FTP habituel.
  4. Accédez à ce fichier dans votre navigateur qui doit normalement se trouver à cette adresse URL : http://VOTRE_NOM_DE_DOMAINE/info.php

Cette page affiche alors une liste complète des fonctionnalités disponibles sur votre serveur d'hébergement et notamment les versions de PHP et de MySQL installées. 

Hébergé par Easy Hébergement